# Hyper V setup, remove port number in URL

**URL:** <https://community.kinsta.com/t/hyper-v-setup-remove-port-number-in-url/1890>\
**Category:** Installation\
**Created:** [November 21, 2022, 4:57pm UTC](https://community.kinsta.com/t/hyper-v-setup-remove-port-number-in-url/1890 "2022-11-21T16:57:49Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![jwhennink](https://avatars.discourse-cdn.com/v4/letter/j/ba9def/32.png) [@jwhennink](https://community.kinsta.com/u/jwhennink)\
**Post date:** [November 21, 2022, 4:57pm UTC](https://community.kinsta.com/t/hyper-v-setup-remove-port-number-in-url/1890/1 "2022-11-21T16:57:49Z")

</div>

Hi, I used to have DevKinsta installed (Windows 11) using WSL 2 (Docker). Though this worked, it was terribly slow.

Then I switched to Hyper V (Installed the Hyper V service), and wordpress performs how it used to be.

Thing is, my URL now has a port number. [http://pwp-website.local:62170/](http://pwp-website.local:62170/)

In my WSL 2 setup, this portnumber was not present.

Activating Elementor Pro, I get an error. Elementor support indicated this is due to the port number behind the URL.

Is there any way to configure Hyper V / Docker / DevKinsta to not have this port number, so I can activate my Elementor Pro license again?

Thank you!

---

<div class="post-metadata">

**Author:** ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)\
**Post date:** [November 21, 2022, 5:04pm UTC](https://community.kinsta.com/t/hyper-v-setup-remove-port-number-in-url/1890/2 "2022-11-21T17:04:59Z")

</div>

Hi @jwhennink, thanks for reaching out!  
Please go to your DevKinsta settings page and manually change the ports to 80 and 443:

 ![image](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/0/07efce659d73efd4919e5d054a9e7cb140fa9a43.png)

If it complains about those ports being in use, you might have another application using them.

---

<div class="post-metadata">

**Author:** ![jwhennink](https://avatars.discourse-cdn.com/v4/letter/j/ba9def/32.png) [@jwhennink](https://community.kinsta.com/u/jwhennink)\
**Post date:** [November 21, 2022, 5:22pm UTC](https://community.kinsta.com/t/hyper-v-setup-remove-port-number-in-url/1890/3 "2022-11-21T17:22:31Z")

</div>

thnx Kevin for your quick reply!  
I get the following error (all my sites are stopped):  
errors.PORT\_SELECTOR\_BACKUP\_ERROR DK0068  
Do you know how to fix?

---

<div class="post-metadata">

**Author:** ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)\
**Post date:** [November 21, 2022, 6:27pm UTC](https://community.kinsta.com/t/hyper-v-setup-remove-port-number-in-url/1890/4 "2022-11-21T18:27:19Z")

</div>

That’s a new one; I’ve never seen that error before. Can you please privately share your main.log file with me?  
[![image](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/6/6c6177f028cf3dd26b939c53fee661fcb28a6390.png)](https://kinsta.com/knowledgebase/devkinsta/error-codes/#info)

---

<div class="post-metadata">

**Author:** ![jwhennink](https://avatars.discourse-cdn.com/v4/letter/j/ba9def/32.png) [@jwhennink](https://community.kinsta.com/u/jwhennink)\
**Post date:** [November 21, 2022, 6:42pm UTC](https://community.kinsta.com/t/hyper-v-setup-remove-port-number-in-url/1890/5 "2022-11-21T18:42:33Z")

</div>

Hi Kevin, PM has been sent!  
Thanks a lot!

---

<div class="post-metadata">

**Author:** ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)\
**Post date:** [November 21, 2022, 6:56pm UTC](https://community.kinsta.com/t/hyper-v-setup-remove-port-number-in-url/1890/6 "2022-11-21T18:56:57Z")

</div>

Thanks for that @jwhennink!  
So the errors are definitely because of the switch to Hyper-V. Your old databases for previous sites still exist if you switch back to WSL2 but they don’t exist under Hyper-V.

The process is trying to backup all of your sites but is running into a database connection error for the sites that you had under WSL2.

So you have a few options.

1. You can switch back to WSL2 then delete your sites from DevKinsta before switching back to Hyper-V(this would be best for the longterm).

or

1. If you are comfortable with editing JSON, you could edit your `config.json` and manually change the Ports (`C:\Users\USERNAME\AppData\Roaming\DevKinsta\config.json`):  
 ![image](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/2/2993c28fce077a6e9879db623ea4cc0e7fb11588.png)  
Note that doing this would skip the step that takes a backup and runs a search and replace for the port number in your databases. You would have to do that manually as well. Also be sure to completely close DevKinsta from the Task Manager before starting it up again after you edit this file.

or

1. Push any sites you have right now to Staging(or make backups of them), then reset Docker and completely uninstall DevKinsta so that you start fresh:  
[Uninstall DevKinsta](https://kinsta.com/knowledgebase/devkinsta/uninstall-devkinsta/#windows-1)

The main issue is that Docker keeps the WSL and Hyper-V database volumes separate.

---

<div class="post-metadata">

**Author:** ![jwhennink](https://avatars.discourse-cdn.com/v4/letter/j/ba9def/32.png) [@jwhennink](https://community.kinsta.com/u/jwhennink)\
**Post date:** [November 21, 2022, 7:28pm UTC](https://community.kinsta.com/t/hyper-v-setup-remove-port-number-in-url/1890/7 "2022-11-21T19:28:33Z")

</div>

Kevin, you are amazing!

I went for option 1, switched back to WSL 2 and deleted all sited created with WSL 2.  
Then switched back to Hyper V and changed ports.  
This process went great now, without errors.

Then I could start my site (now without port number postfix) and was able to activate Elementor Pro.

Thanks a million!

Now I have a lot of work to catch up!!

Thanksss!!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/8/80f8c4e56fecc02327a0964e6bf63a716483529f.png) [@system](https://community.kinsta.com/u/system)\
**Post date:** [November 24, 2022, 7:29pm UTC](https://community.kinsta.com/t/hyper-v-setup-remove-port-number-in-url/1890/8 "2022-11-24T19:29:12Z")

</div>

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.
